Saiu a nova versão do Openfire.

Além das correções de bugs, algumas novidades:

  • Melhorias na performance de login
  • Otimização geral de performance
  • Otimização do consumo de memória quando usando http-bindings
  • Pacote para Solaris
  • Pacotes para Debian/Ubuntu (já era hora) 🙂
  • Entre outras

A lista completa pode ser vista aqui.

Para mim que sou usuário de Debian/Ubuntu, o grande destaque é que finalmente foi criado um pacote de instalação para a distro.

Além disso, foram também disponibilizados 2 novos plugins:

  • Email Listener: O plugin email listener é um serviço que conecta a um servidor IMAP e encaminha novos e-mails para usuários específicos.
  • MotD: O plugin MotD (Message of the Day) permite que os admins enviem mensagens para um usuário sempre que ele logar.

Em breve estarei atualizando o servidor e instalando esses novos plugins. Se forem realmente interessantes eles irão ganhar um post específico.

Agora é baixar e usar 🙂

UPDATE (29/12): Bola fora do pessoal da Ignite Realtime???

Ao tentar instalar o pacote Debian do Openfire recebi a mensagem de que ele depende do pacote sun-java5-jre. Só que eu já tenho o pacote sun-java6-jre e gostaria de usar esse e não precisar instalar o antigo, até porque eu já estou rodando a versão 3.4.1 com o java6. Vou postar uma mensagem pra eles sobre isso…

UPDATE2 (29/12): Segue a posição do pessoal da Ignite:
Howdy! I was working with one of the Ubuntu developers on that package and we decided to go with the java5 requirement for now. There were, unfortunately, a number of things I needed but could not depend on. Most of which was, no /etc/alternatives/jre that would have been provided by any of the packages. It’s easy for my to set a depends of sun-java5-jre | sun-java6-jre, but I have to set JAVA_HOME at one point. =(

One of my tasks though is to hop on the debian java list and see if there is a workaround!

If you skip the requirement, you may need to tweak some variables in the init script, but otherwise you should be good to go!”

Do meu ponto de vista, o principal motivo dessa dependência é que como o pacote do Openfire é o mesmo para Debian e Ubuntu e o Debian só possui o sun-java5-jre (o sun-java6-jre só tem pra Ubuntu), esse acabou sendo o “pacote padrão” de dependência.

ERRATA (30/12):
Me referi erroneamente ao plugin MotD como novo, mas na realidade o mesmo recebeu uma atualização (1.0.3) no dia 27/12, mesma data do lançamento do Openfire 3.4.3 e do plugin Email Listener.

Openfire 3.4.3 disponível e novos plugins lançados
Social Media Icons Powered by Acurax Web Design Company
Optimization WordPress Plugins & Solutions by W3 EDGE
%d blogueiros gostam disto: